SaaS Instance Outage
Incident Report for PortSwigger
Resolved
All SaaS instances are in a healthy state. A postmortem is available at: https://github.com/portswigger-cloud/postmortems/blob/main/2024/10/saas-outage.md
Posted Oct 24, 2024 - 10:15 BST
Monitoring
We have re-deployed all affected instances with the known good version: 1.25.0. SaaS instances are coming back online.
Posted Oct 24, 2024 - 10:05 BST
Identified
We have identified that a machine image of the underlying host OS, Bottlerocket has caused failures of Java, NodeJS and other application startup. The issue in Bottlerocket is tracked in this GitHub Issue: https://github.com/bottlerocket-os/bottlerocket/issues/4253 - we will revert all nodes to the known good version 1.25.0.
Posted Oct 24, 2024 - 09:55 BST
Investigating
We have been notified that a number of SaaS instances are unavailable and are investigating.
Posted Oct 24, 2024 - 09:30 BST
This incident affected: BurpSuite Enterprise Cloud (SaaS Instances).